summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:25:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:25:52 +0300
commit85fb79f1f668042f72227bff6a33c3c6bd3df187 (patch)
treec3fbacee82fe18da9dc1b4d910fb29b2d947401e /gnu/packages/python-xyz.scm
parent0d6fffc5fd8f37b5b49220f67c39548108768b60 (diff)
downloadguix-patches-85fb79f1f668042f72227bff6a33c3c6bd3df187.tar
guix-patches-85fb79f1f668042f72227bff6a33c3c6bd3df187.tar.gz
gnu: Add python-lazr-config.
* gnu/packages/python-xyz.scm (python-lazr-config): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db05a52d14..ef7a4f31c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20681,3 +20681,37 @@ delegate behavior to another object. The new object adds some property or
behavior on to the other object, while still providing the underlying interface,
and delegating behavior.")
(license license:lgpl3)))
+
+(define-public python-lazr-config
+ (package
+ (name "python-lazr-config")
+ (version "2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lazr.config" version))
+ (sha256
+ (base32
+ "11xpddgyhyj7sf27wbmrq5lnqk21wnprx3ajycgwlxjamh6sgffd"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "-s" "-m" "nose" "-P" "lazr"))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-lazr-delegates" ,python-lazr-delegates)
+ ("python-zope-interface" ,python-zope-interface)))
+ (home-page "https://launchpad.net/lazr.config")
+ (synopsis "Create configuration schemas and process and validate configurations")
+ (description
+ "The LAZR config system is typically used to manage process configuration.
+Process configuration is for saying how things change when we run systems on
+different machines, or under different circumstances. This system uses ini-like
+file format of section, keys, and values. The config file supports inheritance
+to minimize duplication of information across files. The format supports schema
+validation.")
+ (license license:lgpl3)))