summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-17 18:24:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-19 00:01:49 +0100
commit8451ea19bcf8ebc98ea52beddbf6245c3d3b353c (patch)
tree57ee9216677ad2ef93044b1fbfb8bc8bb3fc505f /gnu/packages/python-xyz.scm
parent073723fa9a60dc8421223fcd2f54d265027b3806 (diff)
downloadguix-patches-8451ea19bcf8ebc98ea52beddbf6245c3d3b353c.tar
guix-patches-8451ea19bcf8ebc98ea52beddbf6245c3d3b353c.tar.gz
gnu: Add python-pox.
* gnu/packages/python-xyz.scm (python-pox): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 25c6f9c0a5..951571bf2e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16934,3 +16934,41 @@ parallel-enabled applications for @dfn{symmetric multiprocessing} (SMP)
computers and clusters. It features cross-platform portability and dynamic
load balancing.")
(license license:bsd-3)))
+
+(define-public python-pox
+ (package
+ (name "python-pox")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pox" version))
+ (sha256
+ (base32
+ "0y17ckc2p6i6709s279sjdj4q459mpcc38ymg9zv9y6vl6jf3bq6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (mkdir-p "/tmp/guix")
+ (setenv "SHELL" "bash")
+ (setenv "USERNAME" "guix")
+ (setenv "HOME" "/tmp/guix") ; must end on USERNAME...
+ (invoke "py.test" "-vv")
+ #t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("which" ,which)))
+ (home-page "https://pypi.org/project/pox/")
+ (synopsis "Python utilities for filesystem exploration and automated builds")
+ (description
+ "Pox provides a collection of utilities for navigating and manipulating
+filesystems. This module is designed to facilitate some of the low level
+operating system interactions that are useful when exploring a filesystem on a
+remote host. Pox provides Python equivalents of several shell commands such
+as @command{which} and @command{find}. These commands allow automated
+discovery of what has been installed on an operating system, and where the
+essential tools are located.")
+ (license license:bsd-3)))