summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-20 09:15:42 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 10:26:47 +0200
commit7f06ab7fc0429fa736fd77cb1ebe5a69f9909f65 (patch)
treec60b56612926716e293bacb1f5d4c30137f80724 /gnu/packages/python-xyz.scm
parent2bcaf11d7cdd6825aa9b83d5338c4a35d5715997 (diff)
downloadguix-patches-7f06ab7fc0429fa736fd77cb1ebe5a69f9909f65.tar
guix-patches-7f06ab7fc0429fa736fd77cb1ebe5a69f9909f65.tar.gz
gnu: python-nbformat: Enable tests.
* gnu/packages/python-xyz.scm (python-nbformat) [source]: Use git repository, which has more complete test data. [arguments]: Run pytest during 'check. [native-inputs]: Add dependencies required to do that.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2dbbbb33e5..ea67dfc78f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10415,21 +10415,35 @@ drafts 04, 06 and 07.")
(package
(name "python-nbformat")
(version "5.1.3")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "nbformat" version))
- (sha256
- (base32
- "1j6idwsw59cslsssvlkg2bkfpvd6ri7kghbp14jwcw87sy57h5mm"))))
+ ;; The PyPi release tarball lacks some test cases and test data.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jupyter/nbformat.git")
+ (commit version)))
+ (sha256
+ (base32
+ "033v16cfmxzh3jn5phnil4p3silr49iwh9wiigzhv0crc6sanvwz"))
+ (file-name (git-file-name name version))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(propagated-inputs
`(("python-ipython-genutils" ,python-ipython-genutils)
("python-jsonschema" ,python-jsonschema)
("python-jupyter-core" ,python-jupyter-core)
("python-traitlets" ,python-traitlets)))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)
+ ("python-fastjsonschema" ,python-fastjsonschema) ; This is only active
+ ; when setting NBFORMAT_VALIDATOR="fastjsonschema", so include it for
+ ; testing only.
+ ("python-testpath" ,python-testpath)))
(home-page "https://jupyter.org")
(synopsis "Jupyter Notebook format")
(description "This package provides the reference implementation of the