summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-02-21 10:35:45 +0100
committerLars-Dominik Braun <lars@6xq.net>2022-02-21 10:41:26 +0100
commit7eefff2054b94f8a7ad850ad8f36b8773bb39ce9 (patch)
tree3eac9ce67e5b63c94c2f7d3c2287fba60a561575 /gnu/packages/python-xyz.scm
parent0917cbffcd3ce48c50a8467b92f337989820f2ac (diff)
downloadguix-patches-7eefff2054b94f8a7ad850ad8f36b8773bb39ce9.tar
guix-patches-7eefff2054b94f8a7ad850ad8f36b8773bb39ce9.tar.gz
gnu: python-nbconvert: Fix PDF generation.
* gnu/packages/python-xyz.scm (python-nbconvert)[native-inputs]: Move texlive packages… [propagated-inputs]: …here.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm69
1 files changed, 35 insertions, 34 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 516fa4057f..c560781582 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12762,39 +12762,7 @@ time.")
;;("python-pyppeteer" ,python-pyppeteer)
("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-dependency" ,python-pytest-dependency)
- ("texlive" ,(texlive-updmap.cfg (list texlive-adjustbox
- texlive-amsfonts
- texlive-booktabs
- texlive-caption
- texlive-enumitem
- texlive-eurosym
- texlive-fonts-rsfs
- texlive-generic-iftex
- texlive-jknappen
- texlive-latex-amsmath
- texlive-latex-fancyvrb
- texlive-latex-float
- texlive-fontspec
- texlive-latex-geometry
- texlive-grffile
- texlive-hyperref
- texlive-latex-jknapltx
- texlive-latex-ms
- texlive-oberdiek
- texlive-latex-parskip
- texlive-latex-trimspaces
- texlive-latex-upquote
- texlive-latex-ucs
- texlive-lm
- texlive-mathpazo
- texlive-stringenc
- texlive-tcolorbox
- texlive-titling
- texlive-tools
- texlive-ulem
- texlive-xcolor
- texlive-zapfding)))))
+ ("python-pytest-dependency" ,python-pytest-dependency)))
(propagated-inputs
(list python-bleach
python-defusedxml
@@ -12810,7 +12778,40 @@ time.")
python-testpath
python-traitlets
;; Required, even if [serve] is not used.
- python-tornado-6))
+ python-tornado-6
+ ;; Required at runtime for `jupyter nbconvert --to=pdf`.
+ (texlive-updmap.cfg (list texlive-adjustbox
+ texlive-amsfonts
+ texlive-booktabs
+ texlive-caption
+ texlive-enumitem
+ texlive-eurosym
+ texlive-fonts-rsfs
+ texlive-generic-iftex
+ texlive-jknappen
+ texlive-latex-amsmath
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-fontspec
+ texlive-latex-geometry
+ texlive-grffile
+ texlive-hyperref
+ texlive-latex-jknapltx
+ texlive-latex-ms
+ texlive-oberdiek
+ texlive-latex-parskip
+ texlive-latex-trimspaces
+ texlive-latex-upquote
+ texlive-latex-ucs
+ texlive-lm
+ texlive-mathpazo
+ texlive-stringenc
+ texlive-tcolorbox
+ texlive-titling
+ texlive-tools
+ texlive-ulem
+ texlive-xcolor
+ texlive-zapfding))))
(home-page "https://jupyter.org")
(synopsis "Converting Jupyter Notebooks")
(description "The @code{nbconvert} tool, @{jupyter nbconvert}, converts