summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-07 10:24:13 -0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-09 14:44:16 +0300
commit7d7ad3c946897014cc1ccb7094382b21a8f7b45c (patch)
tree39b64f164a106d853d2499737f6e8cbc367d01ee /gnu/packages/python-xyz.scm
parent8809696efaf373e2cdbeaeff4dd436aa7f56df8b (diff)
downloadguix-patches-7d7ad3c946897014cc1ccb7094382b21a8f7b45c.tar
guix-patches-7d7ad3c946897014cc1ccb7094382b21a8f7b45c.tar.gz
gnu: Add python-outcome.
* gnu/packages/python-xyz.scm (python-outcome): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f4ae9df829..58f9d2cc1e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18990,6 +18990,39 @@ easy-to-extend subclass system, and lots of primitive constructs to
make your work easier.")
(license license:expat)))
+(define-public python-outcome
+ (package
+ (name "python-outcome")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "outcome" version))
+ (sha256
+ (base32 "0vxn04vspmlkkyijjkjnsc46f93ki8g62hr7ag10zpd7ic324y7w"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)))
+ (propagated-inputs
+ `(("python-async-generator" ,python-async-generator)
+ ("python-attrs" ,python-attrs)))
+ (home-page "https://github.com/python-trio/outcome")
+ (synopsis "Capture the outcome of Python function calls")
+ (description
+ "Capture the outcome of Python function calls. Extracted from the Trio
+project.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-humanize
(package
(name "python-humanize")