summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-05-29 22:28:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-31 21:05:03 +0200
commit71854b7dfe034dc47655c6fa885bd255fde3c160 (patch)
tree0208bfb01991ef29820a8d8eeae7dbe3ac663c14 /gnu/packages/python-xyz.scm
parentdafd3265ad3a83141f45132f1d154964d82f9039 (diff)
downloadguix-patches-71854b7dfe034dc47655c6fa885bd255fde3c160.tar
guix-patches-71854b7dfe034dc47655c6fa885bd255fde3c160.tar.gz
gnu: Add python-easy-ansi.
* gnu/packages/python-xyz.scm (python-easy-ansi): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b3ed73f04a..886a890049 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16549,6 +16549,30 @@ converting text with ANSI color codes to HTML or LaTeX.")
(define-public python2-ansi2html
(package-with-python2 python-ansi2html))
+(define-public python-easy-ansi
+ (package
+ (name "python-easy-ansi")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/joeysbytes/easy-ansi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0albh55ynzs98qy9pln4qaxw5qhhh3lk09jy9bx19gycrp1c3lc3"))))
+ (build-system python-build-system)
+ (home-page "https://gitlab.com/joeysbytes/easy-ansi")
+ (synopsis "Terminal framework API")
+ (description
+ "Easy ANSI is a terminal framework API to give you an easy way to use
+colors, cursor control movements, and line/box drawing. It is not meant as a
+replacement to more full-featured frameworks (such as curses or urwid), but as
+a tool to quickly create nice-looking screens in your terminal window. You
+can even create animations with the cursor controls.")
+ (license license:expat)))
+
(define-public python-ddt
(package
(name "python-ddt")