summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-28 13:53:29 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-05-02 07:45:26 -0400
commit71005247cd7e77145fb17b3d4b22a803a3078454 (patch)
treec7b0b73179cd0100ccd333d25a699ce495be5bb9 /gnu/packages/python-xyz.scm
parentc1131911a7ff28fde6a027f84c2760c8d5033409 (diff)
downloadguix-patches-71005247cd7e77145fb17b3d4b22a803a3078454.tar
guix-patches-71005247cd7e77145fb17b3d4b22a803a3078454.tar.gz
gnu: Add python-colorful.
* gnu/packages/python-xyz.scm (python-colorful): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3fbb7b3366..67331d1064 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -217,6 +217,34 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-colorful
+ (package
+ (name "python-colorful")
+ (version "0.5.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (pypi-uri "colorful" version))
+ (sha256
+ (base32 "1sh7g2cn1fyz2hzmzs933razdxi2bna9i1lxa790r9pdwba8m146"))))
+ (build-system python-build-system)
+ ;; FIXME: tests cannot be computed:
+ ;; "Can't perform this operation for unregistered loader type"
+ (arguments
+ `(#:tests? #f))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)))
+ (home-page "http://github.com/timofurrer/colorful")
+ (synopsis "Terminal string styling")
+ (description "Colorful provides an array of text styles, that can be used
+as functions or string constants to form colored terminal output.")
+ (license license:expat)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")