summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-24 13:30:24 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 10:02:54 +0200
commit6ff0e43d4ef80b81599cb66432f80784deefc704 (patch)
tree2e09e594a3afaaa6ec3ac116d9f4d07858150863 /gnu/packages/python-xyz.scm
parentda7e6028c8147266590aabb380755a2d9a974889 (diff)
downloadguix-patches-6ff0e43d4ef80b81599cb66432f80784deefc704.tar
guix-patches-6ff0e43d4ef80b81599cb66432f80784deefc704.tar.gz
gnu: Add python-types-orjson.
* gnu/packages/python-xyz.scm (python-types-orjson): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5eac85affe..60f2df85f1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30464,3 +30464,21 @@ sliceables (1 indexed, both start and end index are inclusive). Helps to
slice file content line by line or column by column or a combination of
both.")
(license license:bsd-3)))
+
+(define-public python-types-orjson
+ (package
+ (name "python-types-orjson")
+ (version "3.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-orjson" version))
+ (sha256
+ (base32
+ "0f66lf2qrl9d4vad42db3dmnzv89h4rr05r5zxx5qcl6kb3zr6ng"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for orjson")
+ (description "This is a PEP 561 type stub package for the @code{orjson}
+package. It can be used by type-checking tools like mypy, PyCharm, pytype
+etc. to check code that uses @code{orjson}.")
+ (license license:asl2.0)))