summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-04-14 23:54:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-15 11:09:45 +0300
commit5c2e4711a7c42310907a0e501c31d9d5b4a835dc (patch)
tree6d7548cf4fd378d44599c25054e4df963c5d22e3 /gnu/packages/python-xyz.scm
parent64fe44fa84fb734d3ab4a36c7fd42dea9ce71338 (diff)
downloadguix-patches-5c2e4711a7c42310907a0e501c31d9d5b4a835dc.tar
guix-patches-5c2e4711a7c42310907a0e501c31d9d5b4a835dc.tar.gz
gnu: Add python-setuptools-declarative-requirements.
* gnu/packages/python-xyz.scm (python-setuptools-declarative-requirements): New variable. Co-authored-by: jgart <jgart@dismail.de> Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc1f4597f8..17fdbc4d35 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1275,6 +1275,34 @@ Python 3 support.")
license:asl2.0 ; packaging is dual ASL2/BSD-2
license:bsd-2))))
+(define-public python-setuptools-declarative-requirements
+ (package
+ (name "python-setuptools-declarative-requirements")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri
+ "setuptools-declarative-requirements"
+ version))
+ (sha256
+ (base32
+ "1l8zmcnp9h8sp8hsw7b81djaa1a9yig0y7i4phh5pihqz1gdn7yi"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-toml" ,python-toml)
+ ("python-wheel" ,python-wheel)))
+ (home-page
+ "https://github.com/s0undt3ch/setuptools-declarative-requirements")
+ (synopsis "File support for setuptools declarative setup.cfg")
+ (description
+ "This package provides file support for setuptools declarative
+@code{setup.cfg}.")
+ (license license:asl2.0)))
+
;; The setuptools provided by Python 3.7.4 is too new for Tensorflow.
(define-public python-setuptools-for-tensorflow
(hidden-package