summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 20:19:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 20:36:34 +0100
commit55e1475cb58c1b9535b35f8bdb157b1435c54755 (patch)
treec9183e6b9425a66f084490514046f33fc402e42d /gnu/packages/python-xyz.scm
parentb2205ae4f691c42573af19721fd1bd54f186fb58 (diff)
downloadguix-patches-55e1475cb58c1b9535b35f8bdb157b1435c54755.tar
guix-patches-55e1475cb58c1b9535b35f8bdb157b1435c54755.tar.gz
gnu: python-lxml: Move to (gnu packages xml).
* gnu/packages/python-xyz.scm (python-lxml): Move from here ... * gnu/packages/xml.scm (python-lxml): ... to here. * gnu/packages/django.scm, gnu/packages/drones.scm, gnu/packages/libreoffice.scm, gnu/packages/nutrition.scm, gnu/packages/openstack.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-science.scm, gnu/packages/tryton.scm, gnu/packages/wireservice.scm: Adjust module imports.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1f8b936a12..479466cc81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5784,35 +5784,6 @@ the GObject Introspection bindings to libnotify for non-GTK applications.")
(define-public python2-notify2
(package-with-python2 python-notify2))
-(define-public python-lxml
- (package
- (name "python-lxml")
- (version "4.4.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "lxml" version))
- (sha256
- (base32 "01nvb5j8vs9nk4z5s3250b1m22b4d08kffa36if3g1mdygdrvxpg"))))
- (build-system python-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "make" "test"))))))
- (inputs
- `(("libxml2" ,libxml2)
- ("libxslt" ,libxslt)))
- (home-page "https://lxml.de/")
- (synopsis "Python XML processing library")
- (description
- "The lxml XML toolkit is a Pythonic binding for the C libraries
-libxml2 and libxslt.")
- (license license:bsd-3))) ; and a few more, see LICENSES.txt
-
-(define-public python2-lxml
- (package-with-python2 python-lxml))
-
;; beautifulsoup4 has a totally different namespace than 3.x,
;; and pypi seems to put it under its own name, so I guess we should too
(define-public python-beautifulsoup4