summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2019-12-23 17:30:35 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-23 17:30:35 -0600
commit54e5ee5a360fce0b65f3103470388805558680a7 (patch)
tree625f606386e3884d79dfd7d540650b295fa0a8a6 /gnu/packages/python-xyz.scm
parent65f84096366c810cca8246b9886e7aeddc3a8a30 (diff)
downloadguix-patches-54e5ee5a360fce0b65f3103470388805558680a7.tar
guix-patches-54e5ee5a360fce0b65f3103470388805558680a7.tar.gz
gnu: Add python-flit.
* gnu/packages/python-xyz.scm (python-flit): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d5d958ca07..d7fb2b3176 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16982,3 +16982,27 @@ as @command{which} and @command{find}. These commands allow automated
discovery of what has been installed on an operating system, and where the
essential tools are located.")
(license license:bsd-3)))
+
+(define-public python-flit
+ (package
+ (name "python-flit")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flit" version))
+ (sha256
+ (base32
+ "0h5vvmqinqzn97mr3ix7zx53af9ad4fimjjwqpx88yp8qhz4r5bc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; XXX: Check requires network access.
+ (home-page "https://flit.readthedocs.io/")
+ (synopsis
+ "Simple packaging tool for simple packages")
+ (description
+ "Flit is a simple way to put Python packages and modules on PyPI. Flit
+packages a single importable module or package at a time, using the import
+name as the name on PyPI. All subpackages and data files within a package
+are included automatically.")
+ (license license:bsd-3)))