summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-02-25 13:05:20 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:24 -0400
commit506b3299f3824d09c75855cbaf32d540ef706224 (patch)
treeefb99e362b1f2c3de219ed18c571c4209f8c1eeb /gnu/packages/python-xyz.scm
parent944640f3ee07f88a08d8318e72df5fb2bd6328a2 (diff)
downloadguix-patches-506b3299f3824d09c75855cbaf32d540ef706224.tar
guix-patches-506b3299f3824d09c75855cbaf32d540ef706224.tar.gz
gnu: Add python-zeroconf.
* gnu/packages/python-xyz.scm (python-zeroconf): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c52c70ec89..721171a4fb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21013,6 +21013,39 @@ by Igor Pavlov.")
enumeration library in Python.")
(license license:expat)))
+(define-public python-zeroconf
+ (package
+ (name "python-zeroconf")
+ (version "0.28.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zeroconf" version))
+ (sha256
+ (base32
+ "0narq8haa3b375vfblbyil77n8bw0wxqnanl91pl0wwwm884mqjb"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-ifaddr" ,python-ifaddr)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ ;; Networking isn't available for these tests.
+ (invoke "nosetests" "-v"
+ "--exclude" "test_integration_with_listener_ipv6"
+ "--exclude" "test_launch_and_close_v6_only"
+ "--exclude" "test_launch_and_close_v4_v6"
+ "--exclude" "test_launch_and_close"))))))
+ (home-page "https://github.com/jstasiak/python-zeroconf")
+ (synopsis "Pure Python mDNS service discovery")
+ (description
+ "Pure Python multicast DNS (mDNS) service discovery library (Bonjour/Avahi
+compatible).")
+ (license license:lgpl2.1+)))
+
(define-public python2-zeroconf
(package
(name "python2-zeroconf")