summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:55:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:55:55 +0300
commit4c03a607830f8ef550190fcceda18800e29cabb3 (patch)
treee57b44d591857f9a98c6562eb623199d73179d93 /gnu/packages/python-xyz.scm
parenta1d406e829e7f8fe95da24b5d6507ac53d0e24c0 (diff)
downloadguix-patches-4c03a607830f8ef550190fcceda18800e29cabb3.tar
guix-patches-4c03a607830f8ef550190fcceda18800e29cabb3.tar.gz
gnu: Add python-blessed.
* gnu/packages/python-xyz.scm (python-blessed): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b974843817..bb99f054bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20590,3 +20590,34 @@ For the most part it's transliterated from C, the major differences are:
(description
"Jinxed is an implementation of a subset of the Python curses library.")
(license license:mpl2.0)))
+
+(define-public python-blessed
+ (package
+ (name "python-blessed")
+ (version "1.17.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "blessed" version))
+ (sha256
+ (base32
+ "1wdj342sk22hfrg0n91x2qnqsbzbiyq9y009v3pxnvfzn9bx0wbn"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Don't get hung up on Windows test failures.
+ (delete-file "blessed/win_terminal.py") #t))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-jinxed" ,python-jinxed)
+ ("python-six" ,python-six)
+ ("python-wcwidth" ,python-wcwidth)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/jquast/blessed")
+ (synopsis "Wrapper around terminal capabilities")
+ (description
+ "Blessed is a thin, practical wrapper around terminal styling, screen
+positioning, and keyboard input.")
+ (license license:expat)))