summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-09 15:16:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-09 15:23:36 -0500
commit48e049b38d756771824fb71c6bc476bdcc2d1d16 (patch)
treea4e0a483391e38a8e8c64c52bbfe3a4d3f81b81e /gnu/packages/python-xyz.scm
parentebd2093b32942756fa376833786e0cc70fc9765f (diff)
downloadguix-patches-48e049b38d756771824fb71c6bc476bdcc2d1d16.tar
guix-patches-48e049b38d756771824fb71c6bc476bdcc2d1d16.tar.gz
gnu: python-robotframework-sshlibrary: Normalize doc location.
* gnu/packages/python-xyz.scm (python-robotframework-sshlibrary): [phases]{build-and-install-doc}: Install HTML documentation to the share/doc subdirectory of the 'doc' output.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1387f1f260..4da68a91ca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4872,9 +4872,9 @@ trace directly to the terminal to ease debugging.")
(modify-phases %standard-phases
(add-before 'build 'build-and-install-doc
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((doc-output (assoc-ref outputs "doc"))
- (doc (string-append doc-output "/share/"
- ,name "-" ,version "/")))
+ (let ((doc (string-append
+ (assoc-ref outputs "doc")
+ "/share/doc/robotframework-sshlibrary")))
(invoke "chmod" "-R" "+w" "docs")
(invoke "invoke" "kw-docs" "project-docs")
(mkdir-p doc)