summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-24 09:01:41 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:57 +0200
commit48443dc8805fc398a1108dbde86e077b0646cf30 (patch)
tree2df39d9d13f102e7dbf6bfb1dabe26959f1c7d8c /gnu/packages/python-xyz.scm
parent9c4d0d29a25def622ff2020ca472d464259cff13 (diff)
downloadguix-patches-48443dc8805fc398a1108dbde86e077b0646cf30.tar
guix-patches-48443dc8805fc398a1108dbde86e077b0646cf30.tar.gz
gnu: Add python-identify.
* gnu/packages/python-xyz.scm (python-identify): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2ec1fc88c..031ce91885 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -162,6 +162,7 @@
#:use-module (gnu packages terminals)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
@@ -17487,6 +17488,40 @@ library to allow local file system access via @code{file://} URLs.")
(define-public python2-requests-file
(package-with-python2 python-requests-file))
+(define-public python-identify
+ (package
+ (name "python-identify")
+ (version "1.4.25")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chriskuehl/identify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-editdistance" ,python-editdistance)))
+ (home-page "https://github.com/chriskuehl/identify")
+ (synopsis "File identification library for Python")
+ (description
+ "@code{identify} is a file identification library for Python. Given
+a file (or some information about a file), return a set of standardized tags
+identifying what the file is.")
+ (license license:expat)))
+
(define-public python-tldextract
(package
(name "python-tldextract")