summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-25 03:26:01 +0000
committerLeo Famulari <leo@famulari.name>2021-04-25 14:49:56 -0400
commit45d80c72dc9b4f1aad1bd6e90313a73ee8a4f64a (patch)
tree010c1821d14e590e12617a2566d59925b0d8402b /gnu/packages/python-xyz.scm
parent50847139f4e3adc30370997dfb280c93f512fcbd (diff)
downloadguix-patches-45d80c72dc9b4f1aad1bd6e90313a73ee8a4f64a.tar
guix-patches-45d80c72dc9b4f1aad1bd6e90313a73ee8a4f64a.tar.gz
gnu: Add python-qasync.
* gnu/packages/python-xyz.scm (python-qasync): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index df2d1e9245..d2e4f92820 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12633,6 +12633,41 @@ and PySide6. It is intended for use in mathematics, scientific or engineering
applications.")
(license license:expat)))
+(define-public python-qasync
+ (package
+ (name "python-qasync")
+ (version "0.15.0")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CabbageDevelopment/qasync/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0va9h6v102d7mxz608banjc0l0v02dq3ywhr5i4nqaxx3qkazc2l"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-qpa
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (propagated-inputs
+ `(("python-pyqt" ,python-pyqt)))
+ (home-page "https://github.com/CabbageDevelopment/qasync")
+ (synopsis "Implementation of the PEP 3156 Event-Loop with Qt")
+ (description
+ "@code{qasync} allows coroutines to be used in PyQt/PySide applications
+by providing an implementation of the PEP 3156 event-loop.")
+ (license license:bsd-2)))
+
(define-public python-editor
(package
(name "python-editor")