summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:54:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:09:58 +0300
commit41eb9da3886af857088b95ebadaa38fa173cd459 (patch)
treee12ed8c090a4c90d67dda1a2d9d2ccd5bed137c2 /gnu/packages/python-xyz.scm
parent3a98604f5f282fa2ba025bc9f9418c1cfe5bd54c (diff)
downloadguix-patches-41eb9da3886af857088b95ebadaa38fa173cd459.tar
guix-patches-41eb9da3886af857088b95ebadaa38fa173cd459.tar.gz
gnu: Add python-rjsmin.
* gnu/packages/python-xyz.scm (python-rjsmin): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index beaed485bd..e16d3daf54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13545,6 +13545,43 @@ network.")
(define-public python2-argcomplete
(package-with-python2 python-argcomplete))
+(define-public python-rjsmin
+ (package
+ (name "python-rjsmin")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rjsmin" version))
+ (sha256
+ (base32
+ "0cmc72rlkvzz8fl89bc83czkx0pcvhzj7yn7m29r8pgnf5fcfpdi"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "bench" "\\.js$"))
+ #t))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ; Not all test files included.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (if tests?
+ (invoke "py.test" "-vv" "tests")
+ #t))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "http://opensource.perlig.de/rjsmin/")
+ (synopsis "Javascript Minifier")
+ (description "@code{rJSmin} is a javascript minifier written in Python. The
+minifier is based on the semantics of jsmin.c by Douglas Crockford. The module
+is a re-implementation aiming for speed, so it can be used at runtime (rather
+than during a preprocessing step).")
+ (license license:asl2.0)))
+
(define-public python-xopen
(package
(name "python-xopen")