summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-27 00:11:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-27 23:28:06 +0200
commit3f68322e5a0073ffe1209dee430f30168cda2b96 (patch)
tree787116661ef1dda6da49a1f497c9c3e150b96afa /gnu/packages/python-xyz.scm
parentbc3693743127accce674faa70f8b7326f6439eea (diff)
downloadguix-patches-3f68322e5a0073ffe1209dee430f30168cda2b96.tar
guix-patches-3f68322e5a0073ffe1209dee430f30168cda2b96.tar.gz
gnu: python-setproctitle: Fix build.
* gnu/packages/python-xyz.scm (python-setproctitle)[arguments]: Add ‘--embed’ to $PYCONFIG.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 463bfbf3bd..a526fc29b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13149,8 +13149,9 @@ English stemmer.")
(replace 'check
(lambda _
(setenv "PYTHON" (or (which "python3") (which "python")))
- (setenv "PYCONFIG" (or (which "python3-config")
- (which "python-config")))
+ (setenv "PYCONFIG" (string-append (or (which "python3-config")
+ (which "python-config"))
+ " --embed"))
(setenv "CC" "gcc")
;; No need to extend PYTHONPATH to find the built package, since
;; the Makefile will build anyway