summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-07-22 12:44:37 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-04 12:05:53 +0200
commit3bd2b1b544c45e5e341010e48bcedcb0ba593480 (patch)
tree9aba1d1f6f72f73d74263608e34dd0179bc31820 /gnu/packages/python-xyz.scm
parent58d196866a3766480a79a935264b761df1524daf (diff)
downloadguix-patches-3bd2b1b544c45e5e341010e48bcedcb0ba593480.tar
guix-patches-3bd2b1b544c45e5e341010e48bcedcb0ba593480.tar.gz
gnu: Add python-h5netcdf.
* gnu/packages/python-xyz.scm: (python-h5netcdf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9266e4281..d02501684f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1476,6 +1476,37 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
@url{http://hdfeos.org/software/pyhdf.php,pyhdf}.")
(license license:expat)))
+(define-public python-h5netcdf
+ (package
+ (name "python-h5netcdf")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "h5netcdf" version))
+ (sha256
+ (base32 "1b2dcgf5rwy7pb7hr4prkc5vgcw9qc2was20dmnj90lbrpx08rvp"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "h5netcdf/tests")))))))
+ (native-inputs
+ (list python-netcdf4
+ python-pytest
+ python-setuptools-scm))
+ (propagated-inputs
+ (list python-h5py python-packaging))
+ (home-page "https://h5netcdf.org")
+ (synopsis "Python interface for the netCDF4 file-format based on h5py")
+ (description "This package provides Python interface for the netCDF4
+file-format that reads and writes local or remote HDF5 files directly via h5py
+or h5pyd, without relying on the Unidata netCDF library")
+ (license license:bsd-3)))
+
(define-public python-h5py
(package
(name "python-h5py")