summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-26 13:08:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-06-26 13:11:48 -0400
commit2aa802ee5e871cbe99b3735ec9197454247b1c55 (patch)
tree97020538dd4a93a58045eb26b6c10728d9f0b801 /gnu/packages/python-xyz.scm
parent5a13e950b2bd0860ee91bcd61a2a3c1a1ec0f616 (diff)
downloadguix-patches-2aa802ee5e871cbe99b3735ec9197454247b1c55.tar
guix-patches-2aa802ee5e871cbe99b3735ec9197454247b1c55.tar.gz
gnu: Add python-twodict.
* gnu/packages/python-xyz (python-twodict): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ec4209108f..6b92200beb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -100,6 +100,7 @@
;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -219,6 +220,25 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-twodict
+ (package
+ (name "python-twodict")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "twodict" version))
+ (sha256
+ (base32 "0ifv7dv18jn2lg0a3l6zdlvmmlda2ivixfjbsda58a2ay6kxznr0"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/MrS0m30n3/twodict")
+ (synopsis "Two way ordered dictionary for Python")
+ (description "TwoDict is a custom dictionary in which you can get the
+key:value relationship but you can also get the value:key relationship. It also
+remembers the order in which the items were inserted and supports almost all the
+features of the Python's built-in dict.")
+ (license license:unlicense)))
+
(define-public python-argopt
(package
(name "python-argopt")