summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-20 11:15:30 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 10:37:07 +0200
commit2209e5c7531bfe5e81c86f0a581d16569ee9b719 (patch)
tree1a855774056ca4104399dbc99bdc98ddaf49eb0f /gnu/packages/python-xyz.scm
parentd57341234d66ba71618ed401d8bb0a5986dc22db (diff)
downloadguix-patches-2209e5c7531bfe5e81c86f0a581d16569ee9b719.tar
guix-patches-2209e5c7531bfe5e81c86f0a581d16569ee9b719.tar.gz
gnu: python-notebook: Fix tests.
They failed because JUPYTER_PATH was set in commit 1683e9d9677d54f695a54fc44ed309287989fc34. * gnu/packages/python-xyz.scm (python-notebook) [#:phases]: Unset JUPYTER_PATH in 'check.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3942135ae3..2d33597ba9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10807,6 +10807,9 @@ convert an @code{.ipynb} notebook file into various static formats including:
(delete-file-recursively "notebook/tests/selenium")
(when tests?
(add-installed-pythonpath inputs outputs)
+ ;; Some tests do not expect all files to be installed in the
+ ;; same directory, but JUPYTER_PATH contains multiple entries.
+ (unsetenv "JUPYTER_PATH")
;; Some tests need HOME
(setenv "HOME" "/tmp")
(with-directory-excursion "/tmp"