summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 08:35:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:17 +0200
commit2043e7bfc8786a4831247da7095c1e623ad1c4d0 (patch)
treefba4dc46d69fd03fea4a0d6902a3d94b8648d963 /gnu/packages/python-xyz.scm
parent6d0a3dc4bc98ebcda0f2ef8d426b2d29c3eaa77e (diff)
downloadguix-patches-2043e7bfc8786a4831247da7095c1e623ad1c4d0.tar
guix-patches-2043e7bfc8786a4831247da7095c1e623ad1c4d0.tar.gz
gnu: Add python-nest-asyncio.
* gnu/packages/python-xyz.scm (python-nest-asyncio): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f837bf7429..67b2172e91 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23851,6 +23851,28 @@ be kept in mind when creating it. It is easily created, modified, or viewed wit
a text editor and easily understood and used by both programmers and non-programmers.")
(license license:expat))) ; MIT license
+(define-public python-nest-asyncio
+ (package
+ (name "python-nest-asyncio")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nest_asyncio" version))
+ (sha256
+ (base32
+ "1anha29fcijminn5bh2icnx8x7nk39lna9wkc72262i12p2s3idg"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/erdewit/nest_asyncio")
+ (synopsis "Patch asyncio to allow nested event loops")
+ (description
+ "By design @code{asyncio} does not allow its event loop to be nested.
+This presents a practical problem: when in an environment where the event loop
+is already running it's impossible to run tasks and wait for the result. This
+module patches @code{asyncio} to allow nested use of @code{asyncio.run} and
+@code{loop.run_until_complete}.")
+ (license license:bsd-3)))
+
(define-public python-parallel
(package
(name "python-parallel")