summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2022-03-10 18:28:08 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-04 12:05:46 +0200
commit18e00988176162ac736c873dc6cb06169b0aaa3b (patch)
tree4cbbacc74410fd02e4e08e46fc4ebb13b42f8dee /gnu/packages/python-xyz.scm
parentf44c13560885a8751fe59ba2e512a726c1674b1e (diff)
downloadguix-patches-18e00988176162ac736c873dc6cb06169b0aaa3b.tar
guix-patches-18e00988176162ac736c873dc6cb06169b0aaa3b.tar.gz
gnu: python-args: Patch reference to basestring.
Hi Maxime, I **totally** forgot about this one! Seems like no one is using it. `python2-args` also builds. But no package seems to depend on it anyway. Regards, Tanguy * gnu/packages/python-xyz.scm (python-args)[source]: Use the latest version from the git repository to get the test suite. [home-page]: Update URL. [native-inputs]: Add python-nose. [arguments]: Replace reference to basestring with str. Invoke nosetests. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm45
1 files changed, 30 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cf1f009a7f..1be295b140 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14056,21 +14056,36 @@ files for use with Python.")
(license license:bsd-2)))
(define-public python-args
- (package
- (name "python-args")
- (version "0.1.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "args" version))
- (sha256
- (base32
- "057qzi46h5dmxdqknsbrssn78lmqjlnm624iqdhrnpk26zcbi1d7"))))
- (build-system python-build-system)
- (home-page "https://github.com/kennethreitz/args")
- (synopsis "Command-line argument parser")
- (description
- "This library provides a Python module to parse command-line arguments.")
- (license license:bsd-3)))
+ (let ((commit "9460f1a35eb3055e9e4de1f0a6932e0883c72d65") (revision "0"))
+ (package
+ (name "python-args")
+ (version (git-version "0.1.0" revision commit))
+ (home-page "https://github.com/kennethreitz-archive/args")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zfxpbp9vldqdrjmd0c6y3wisl35mx5v8zlyp3nhwpy1730wrc9j"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-args.py
+ (lambda _
+ (substitute* "args.py"
+ (("basestring") "str"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "nosetests" "-v")))))))
+ (native-inputs (list python-nose))
+ (synopsis "Command-line argument parser")
+ (description
+ "This library provides a Python module to parse command-line arguments.")
+ (license license:bsd-3))))
(define-public python-clint
(package