summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-12 08:55:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-12 08:59:29 +0300
commit1518b4bceb9955ed6d94432d651b7a2a9f3052e1 (patch)
treecf3fe6fa92a11612ab30a5ed7d0eb9a81cf25480 /gnu/packages/python-xyz.scm
parentaec0ae27121d8004b7053def6a2b3fe71877e6ab (diff)
downloadguix-patches-1518b4bceb9955ed6d94432d651b7a2a9f3052e1.tar
guix-patches-1518b4bceb9955ed6d94432d651b7a2a9f3052e1.tar.gz
gnu: Remove duplicate python-prometheus-client.
* gnu/packages/monitoring.scm (python-prometheus-client): Update to 0.7.1. * gnu/packages/python-xyz.scm (python-prometheus-client): Remove variable. * gnu/packages/monitoring.scm: Import (gnu packages monitoring).
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ecf7115ab..64b1e6d8dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19236,28 +19236,6 @@ simple and fast to verify, and decouple authorization policy from the
enforcement of that policy.")
(license license:expat)))
-(define-public python-prometheus-client
- (package
- (name "python-prometheus-client")
- (version "0.7.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "prometheus_client" version))
- (sha256
- (base32 "1ni2yv4ixwz32nz39ckia76lvggi7m19y5f702w5qczbnfi29kbi"))))
- (build-system python-build-system)
- (arguments
- ;; TODO: No tests in the PyPI distribution.
- `(#:tests? #f))
- (propagated-inputs
- `(("python-twisted" ,python-twisted)))
- (home-page "https://github.com/prometheus/client_python")
- (synopsis "Prometheus instrumentation library")
- (description
- "This is the official Python client for the Prometheus monitoring server.")
- (license license:asl2.0)))
-
(define-public python-ldap3
(package
(name "python-ldap3")