summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:32:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:32:26 +0300
commit0f1e0882804601e181951b45921b618a7709cb85 (patch)
tree6ef92c7797b5e219177161ef9e406b23e6f77e66 /gnu/packages/python-xyz.scm
parent2bf21531533a22a666a5309d80c045f1dc61fd12 (diff)
downloadguix-patches-0f1e0882804601e181951b45921b618a7709cb85.tar
guix-patches-0f1e0882804601e181951b45921b618a7709cb85.tar.gz
gnu: Add python-flufl-bounce.
* gnu/packages/python-xyz.scm (python-flufl-bounce): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1046aadcd3..612098ece0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20716,6 +20716,32 @@ to minimize duplication of information across files. The format supports schema
validation.")
(license license:lgpl3)))
+(define-public python-flufl-bounce
+ (package
+ (name "python-flufl-bounce")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flufl.bounce" version))
+ (sha256
+ (base32
+ "01lg1b0jpf8605mzaz9miq3nray6s7a7gc8n4wzg5nsxl8fglcp4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-atpublic" ,python-atpublic)
+ ("python-zope-interface" ,python-zope-interface)))
+ (native-inputs
+ `(("python-nose2" ,python-nose2)))
+ (home-page "https://fluflbounce.readthedocs.io/en/latest/")
+ (synopsis "Email bounce detectors")
+ (description "The @code{flufl.bounce} library provides a set of heuristics
+and an API for detecting the original bouncing email addresses from a bounce
+message. Many formats found in the wild are supported, as are VERP and
+RFC 3464.")
+ (license (list license:asl2.0
+ license:lgpl3)))) ; only for setup_headers.py
+
(define-public python-flufl-i18n
(package
(name "python-flufl-i18n")