summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 14:35:42 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 16:04:59 +0200
commit0d0e3bee031d84712ac76c141a8bfdc8e7179868 (patch)
tree047c849b2d06f3d924a0f6ab1bb0e18980447bbe /gnu/packages/python-xyz.scm
parent350833554bddf309aaba1599ff3e43085b10c10e (diff)
downloadguix-patches-0d0e3bee031d84712ac76c141a8bfdc8e7179868.tar
guix-patches-0d0e3bee031d84712ac76c141a8bfdc8e7179868.tar.gz
gnu: python2-cliapp: Add Python 3 variant.
* gnu/packages/python-xyz.scm (python2-cliapp): Rename to ... (python-cliapp): ... this. [name, native-inputs, propagated-inputs]: Adjust accordingly. [arguments]: Disable tests. [description]: Remove mentions of Python version and add markup. (python2-cliapp): Use PACKAGE-WITH-PYTHON2.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 14 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6fcbb14cff..b42b4a6b4c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16859,9 +16859,9 @@ protocols.")
(define-public python2-attrs-bootstrap
(package-with-python2 python-attrs-bootstrap))
-(define-public python2-cliapp
+(define-public python-cliapp
(package
- (name "python2-cliapp")
+ (name "python-cliapp")
(version "1.20180812.1")
(source
(origin
@@ -16874,32 +16874,24 @@ protocols.")
"1c1jlblbns8qhiaqjpg4xi6lip8xwfc5w643p43rg543havaj45x"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; check phase needs to be run before the build phase. If not,
- ;; coverage-test-runner looks for tests for the built source files,
- ;; and fails.
- (delete 'check)
- (add-before 'build 'check
- (lambda _
- ;; Disable python3 tests
- (substitute* "check"
- (("python3") "# python3"))
- (invoke "./check"))))))
+ `(;; XXX: The tests only do style and coverage checks, which
+ ;; fails due to deprecation warnings, etc.
+ #:tests? #f))
(native-inputs
- `(("python2-coverage-test-runner" ,python2-coverage-test-runner)
- ("python2-pep8" ,python2-pep8)))
+ `(("python-coverage-test-runner" ,python-coverage-test-runner)
+ ("python-pep8" ,python-pep8)))
(propagated-inputs
- `(("python2-pyaml" ,python2-pyaml)))
+ `(("python-pyaml" ,python-pyaml)))
(home-page "https://liw.fi/cliapp/")
(synopsis "Python framework for command line programs")
- (description "@code{python2-cliapp} is a python framework for
-command line programs. It contains the typical stuff such programs
-need to do, such as parsing the command line for options, and
-iterating over input files.")
+ (description "@code{cliapp} is a Python framework for command line
+programs. It contains the typical stuff such programs need to do, such
+as parsing the command line for options, and iterating over input files.")
(license license:gpl2+)))
+(define-public python2-cliapp
+ (package-with-python2 python-cliapp))
+
(define-public python2-ttystatus
(package
(name "python2-ttystatus")