summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 18:02:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:54 +0200
commit09f527827a544f8ea3f1b7d0326d4febffdbaf4b (patch)
tree53609fb06744eaba445eebb9eadc04f1cd0f8333 /gnu/packages/python-xyz.scm
parent978d11f96e6ad9818dd005f8279f41a67be69935 (diff)
downloadguix-patches-09f527827a544f8ea3f1b7d0326d4febffdbaf4b.tar
guix-patches-09f527827a544f8ea3f1b7d0326d4febffdbaf4b.tar.gz
gnu: Add python-tifffile.
* gnu/packages/python-xyz.scm (python-tifffile): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ab3323e5f..a728494433 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5342,6 +5342,32 @@ ImageJ ROIs, an undocumented and ImageJ application specific format to store
regions of interest, geometric shapes, paths, text, etc for image overlays.")
(license license:bsd-3)))
+(define-public python-tifffile
+ (package
+ (name "python-tifffile")
+ (version "2020.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tifffile" version))
+ (sha256
+ (base32
+ "0xv3ynkbrsibqvx7250075idb7wm3canjd6lx2nzf3cbp6l07577"))))
+ (build-system python-build-system)
+ ;; Tests require lfdfiles, which depends on tifffile
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ;;("python-lfdfiles" ,python-lfdfiles)
+ ("python-roifile" ,python-roifile)))
+ (home-page "https://www.lfd.uci.edu/~gohlke/")
+ (synopsis "Read and write TIFF(r) files")
+ (description "This package lets you read image and metadata from many
+bio-scientific formats such as plain TIFF, BigTIFF, OME-TIFF, STK, LSM, SGI,
+NIH, ImageJ, MicroManager, MD GEL, and FluoView files. It also lets you write
+numpy arrays to TIFF, BigTIFF, and ImageJ hyperstack compatible files.")
+ (license license:bsd-3)))
+
(define-public python-pycparser
(package
(name "python-pycparser")