summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-09 08:36:16 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-09 15:23:35 -0500
commit09aa025b44c099e669bcda3c38344b270fd7982b (patch)
treef2e71ec0448e03f6bce54f4795987405ebe0561a /gnu/packages/python-xyz.scm
parentedbf4f60e24e40d4dca20775d18873f71057f7f9 (diff)
downloadguix-patches-09aa025b44c099e669bcda3c38344b270fd7982b.tar
guix-patches-09aa025b44c099e669bcda3c38344b270fd7982b.tar.gz
gnu: Add python-trio-websocket.
* gnu/packages/python-xyz.scm (python-trio-websocket): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8ec319626..860ea35959 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23801,6 +23801,40 @@ a mypy plugin that smooths over some limitations in the basic type hints.
;; Either license applies.
(license (list license:expat license:asl2.0))))
+(define-public python-trio-websocket
+ (package
+ (name "python-trio-websocket")
+ (version "0.9.2")
+ (source
+ (origin
+ (method git-fetch) ;no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/HyperionGray/trio-websocket")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yk2ak991kbl30xg8ldpggack1lwkizd7s5cpr28ir34z8iyjnpi"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest python-pytest-trio python-trustme))
+ (propagated-inputs (list python-async-generator python-trio python-wsproto))
+ (home-page "https://github.com/HyperionGray/trio-websocket")
+ (synopsis "WebSocket library for Trio")
+ (description "This library implements both server and client aspects of
+the @url{https://tools.ietf.org/html/rfc6455, the WebSocket protocol},
+striving for safety, correctness, and ergonomics. It is based on the
+@url{https://wsproto.readthedocs.io/en/latest/, wsproto project}, which is a
+@url{https://sans-io.readthedocs.io/, Sans-IO} state machine that implements
+the majority of the WebSocket protocol, including framing, codecs, and events.
+This library handles I/O using @url{https://trio.readthedocs.io/en/latest/,
+the Trio framework}.")
+ (license license:expat)))
+
(define-public python-humanize
(package
(name "python-humanize")