summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-23 13:33:09 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-23 13:33:09 +0200
commit030f6f489fe9544f35ebaf95135acd1dd67ce63f (patch)
treef1d5d1f1b68de81daec6f05d032a0410a475d960 /gnu/packages/python-xyz.scm
parent95c14929a7fbd3c55c5e8756953c2f257625e2b7 (diff)
parent938df0de739aa13c2fb483f440ec1db281a52aaa (diff)
downloadguix-patches-030f6f489fe9544f35ebaf95135acd1dd67ce63f.tar
guix-patches-030f6f489fe9544f35ebaf95135acd1dd67ce63f.tar.gz
Merge branch 'master' into core-updates
Conflicts: etc/news.scm gnu/local.mk gnu/packages/bootloaders.scm gnu/packages/linphone.scm gnu/packages/linux.scm gnu/packages/tls.scm gnu/system.scm
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86f4552cc5..8a2e580ad2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19637,3 +19637,41 @@ randomly picked from wordlists. It supports several sources of
randomness (including real life dice) and different wordlists (including
cryptographically signed ones).")
(license license:gpl3+)))
+
+(define-public pyzo
+ (package
+ (name "pyzo")
+ (version "4.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyzo" version))
+ (sha256
+ (base32 "1zplxcb78qy8qibifmnsx5i9gnlfmw9n6nr4yflsabpxw57mx4m1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-home-directory
+ (lambda _
+ ;; Tests fail with "Permission denied: '/homeless-shelter'".
+ (setenv "HOME" "/tmp")
+ #t)))
+ ;; Tests fail with "Uncaught Python exception: invalid literal for
+ ;; int() with base 10: 'test'".
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-pyqt" ,python-pyqt)))
+ (home-page "https://pyzo.org")
+ (synopsis
+ "Python IDE for scientific computing")
+ (description
+ "Pyzo is a Python IDE focused on interactivity and introspection,
+which makes it very suitable for scientific computing. Its practical
+design is aimed at simplicity and efficiency.
+
+It consists of two main components, the editor and the shell, and uses
+a set of pluggable tools to help the programmer in various ways. Some
+example tools are source structure, project manager, interactive help,
+workspace...")
+ (license license:bsd-2)))