summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-24 19:22:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-24 19:29:43 +0100
commit02422b3b669e120dcd8b8888893a84909b5b9b87 (patch)
tree05124a21b3e9be9d8330d892d691342d8c8ea737 /gnu/packages/python-xyz.scm
parent06b13f51f8efd9955f0e36a9dec6ad958fd48e6d (diff)
downloadguix-patches-02422b3b669e120dcd8b8888893a84909b5b9b87.tar
guix-patches-02422b3b669e120dcd8b8888893a84909b5b9b87.tar.gz
gnu: python-texttable: Update to 1.6.2.
* gnu/packages/python-xyz.scm (python-texttable): Update to 1.6.2. [arguments]: Replace check phase. [native-inputs]: Add python-pytest. [license]: Change to Expat.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bbbb35ce8c..7a335c04b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
@@ -8339,21 +8339,27 @@ the standard library.")
(define-public python-texttable
(package
(name "python-texttable")
- (version "0.9.1")
+ (version "1.6.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "texttable" version))
(sha256
(base32
- "0yawv64c0zbawwv6zz84whb32fnb2n9jylwjcfsrcdgh7xvl340i"))))
+ "1x5l77akfc20x52jma9573qp8l8r07q103pm4l0pbizvh4vp1wzg"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; no tests
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "pytest" "tests.py"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/foutaise/texttable/")
(synopsis "Python module for creating simple ASCII tables")
(description "Texttable is a Python module for creating simple ASCII
tables.")
- (license license:lgpl2.1+)))
+ (license license:expat)))
(define-public python2-texttable
(package-with-python2 python-texttable))