summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorHamzeh Nasajpour <h.nasajpour@pantherx.org>2020-05-29 12:10:49 +0430
committerMarius Bakke <marius@gnu.org>2020-05-30 16:41:40 +0200
commitf55152cec4d200d59bc503c0442b96827dd8c0e2 (patch)
tree0aef204b0dcd0b3a5a1b53d29a8ffeb27cfdb843 /gnu/packages/python-web.scm
parentd6f5120d5b0cc7e92d7ba0dccbccac7339ea1479 (diff)
downloadguix-patches-f55152cec4d200d59bc503c0442b96827dd8c0e2.tar
guix-patches-f55152cec4d200d59bc503c0442b96827dd8c0e2.tar.gz
gnu: python-furl: Update to 2.0.0.
* gnu/packages/python-web.scm (python-furl): Update to 2.0.0. [native-inputs]: Remove PYTHON-PYCODESTYLE. Add PYTHON-FLAKE8. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cd8ce8a83f..61d21418d4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -324,20 +324,20 @@ over a different origin than that of the web application.")
(define-public python-furl
(package
(name "python-furl")
- (version "0.5.6")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "furl" version))
(sha256
(base32
- "0lzpfpm686hvz3sr1mcrnd1b3lgmnw8v59gb43wfi98r3b671pqc"))))
+ "1v2lakx03d5w8954a39ki44xv5mllnq0a0avhxykv9hrzg0yvjpx"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)
("python-orderedmultidict" ,python-orderedmultidict)))
(native-inputs
- `(("python-pycodestyle" ,python-pycodestyle)))
+ `(("python-flake8" ,python-flake8)))
(home-page "https://github.com/gruns/furl")
(synopsis "URL manipulation in Python")
(description "Furl provides an easy-to-use alternative to the