summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 22:59:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:14 -0400
commiteccb33c210e364b2c29c08a148e19f1801310888 (patch)
tree75b33609fd425c6492f8f22e37230cf92d9ca60d /gnu/packages/python-web.scm
parentce6d29988816bb9e0c5f8da775405527f22f2e63 (diff)
downloadguix-patches-eccb33c210e364b2c29c08a148e19f1801310888.tar
guix-patches-eccb33c210e364b2c29c08a148e19f1801310888.tar.gz
gnu: Remove python2-tornado.
* gnu/packages/python-web.scm (python2-tornado): Delete variable. (python-tornado)[properties]: Delete field.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 18722b842a..cc444cf488 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1985,8 +1985,7 @@ originally developed at FriendFeed. By using non-blocking network I/O,
Tornado can scale to tens of thousands of open connections, making it ideal
for long polling, WebSockets, and other applications that require a long-lived
connection to each user.")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-tornado))))))
+ (license license:asl2.0)))
(define-public python-tornado-6
(package
@@ -2019,16 +2018,6 @@ for long polling, WebSockets, and other applications that require a long-lived
connection to each user.")
(license license:asl2.0)))
-(define-public python2-tornado
- (let ((tornado (package-with-python2 (strip-python2-variant python-tornado))))
- (package/inherit tornado
- (propagated-inputs
- `(("python2-backport-ssl-match-hostname"
- ,python2-backport-ssl-match-hostname)
- ("python2-backports-abc" ,python2-backports-abc)
- ("python2-singledispatch" ,python2-singledispatch)
- ,@(package-propagated-inputs tornado))))))
-
(define-public python-tornado-http-auth
(package
(name "python-tornado-http-auth")