summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-30 20:48:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-30 20:48:22 +0100
commite35cfeb25336d9e7a4dcd5ddf8f2345ce195067b (patch)
tree3eb530f335036c0352ae7b39f242bae5c9929856 /gnu/packages/python-web.scm
parent53a16a2143bbc3cc5f9f014ab6fb6afc9d0064d6 (diff)
downloadguix-patches-e35cfeb25336d9e7a4dcd5ddf8f2345ce195067b.tar
guix-patches-e35cfeb25336d9e7a4dcd5ddf8f2345ce195067b.tar.gz
gnu: Add python-pyjsparser.
* gnu/packages/python-web.scm (python-pyjsparser): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5d0cbda0cc..9939a1b238 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5943,6 +5943,23 @@ Agent is a web crawler. It uses the list of registered robots from
using a pure Python implementation.")
(license license:bsd-3)))
+(define-public python-pyjsparser
+ (package
+ (name "python-pyjsparser")
+ (version "2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyjsparser" version))
+ (sha256
+ (base32 "0ycmf9fsvwliqmm1n6sfz7x71y7i2kbfgn39d8lsbiccfxmxlq5y"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/PiotrDabkowski/pyjsparser")
+ (synopsis "Fast JavaScript parser")
+ (description "This package provides a fast JavaScript parser (based on
+esprima.js)")
+ (license license:expat)))
+
(define-public python-http-ece
(package
(name "python-http-ece")