summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-05 01:58:31 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:54 +0100
commitdbf5d938c54dbc0cf3271018a0a4aa5b69ec4037 (patch)
tree5c460e429a9cd7d60aeeeabcb9e739dfe76dee24 /gnu/packages/python-web.scm
parentf3416ebc2e0a10e35f5bab3e7f8f3081bfa75c59 (diff)
downloadguix-patches-dbf5d938c54dbc0cf3271018a0a4aa5b69ec4037.tar
guix-patches-dbf5d938c54dbc0cf3271018a0a4aa5b69ec4037.tar.gz
gnu: python-cfn-lint: Honor #:tests? flag.
* gnu/packages/python-web.scm (python-cfn-lint)[arguments]: Make some cosmetic changes. Adjust custom 'check phase to honor the #:tests? flag. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f47ba86409..063b2c5e73 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -514,23 +514,23 @@ emit information from within their applications to the AWS X-Ray service.")
"106qf19n2k6sdjkb4006aidibd24qqiw901c1613xgjpnyw4dyl6"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Remove test for the documentation update scripts
- ;; to avoid a dependency on 'git'.
- (delete-file
- "test/unit/module/maintenance/test_update_documentation.py")
- (delete-file
- "test/unit/module/maintenance/test_update_resource_specs.py")
- (setenv "PYTHONPATH"
- (string-append "./build/lib:"
- (getenv "PYTHONPATH")))
- (setenv "PATH" (string-append out "/bin:"
- (getenv "PATH")))
- (invoke "python" "-m" "unittest" "discover" "-v"
- "-s" "test")))))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (let ((out (assoc-ref outputs "out")))
+ ;; Remove test for the documentation update scripts
+ ;; to avoid a dependency on 'git'.
+ (delete-file
+ "test/unit/module/maintenance/test_update_documentation.py")
+ (delete-file
+ "test/unit/module/maintenance/test_update_resource_specs.py")
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PATH" (string-append out "/bin:"
+ (getenv "PATH")))
+ (invoke "python" "-m" "unittest" "discover"
+ "-s" "test"))))))))
(native-inputs
`(("python-pydot" ,python-pydot)
("python-mock" ,python-mock)))