summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-27 23:26:50 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:14 +0200
commitc47e551402cf6492fcc2b9e9719f074cb45d6e0d (patch)
treeabd2a15102e5185cc4fe7a4678c7ed25f87c67f8 /gnu/packages/python-web.scm
parent57bba2ee54fa67de66fd76e66868ac863fa5056a (diff)
downloadguix-patches-c47e551402cf6492fcc2b9e9719f074cb45d6e0d.tar
guix-patches-c47e551402cf6492fcc2b9e9719f074cb45d6e0d.tar.gz
gnu: Add python-socks.
* gnu/packages/python-web.scm (python-socks): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bdde4d90f4..66af408920 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5724,3 +5724,38 @@ that's written to go fast. It allows the usage of the
@code{async/await} syntax added in Python 3.5, which makes
your code non-blocking and speedy.")
(license license:expat)))
+
+(define-public python-socks
+ (package
+ (name "python-socks")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-socks" version))
+ (sha256
+ (base32
+ "06mgv3icsyglv50w3sb71x6cpbskza20pqd93l5xk59x574i6xgs"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; tests not included
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "tests/" "-s"))
+ #t)))))
+ (propagated-inputs
+ `(("python-async-timeout" ,python-async-timeout)
+ ("python-curio" ,python-curio)
+ ("python-trio" ,python-trio)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/romis2012/python-socks")
+ (synopsis
+ "Core proxy (SOCKS4, SOCKS5, HTTP tunneling) functionality for Python")
+ (description
+ "Socks is a library providing core proxy (SOCKS4, SOCKS5, HTTP tunneling)
+ functionality.")
+ (license license:asl2.0)))