summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authormsimonin <matthieu.simonin@inria.fr>2022-08-30 11:00:19 +0200
committerMarius Bakke <marius@gnu.org>2022-08-30 17:59:18 +0200
commitc19a432652f2fb544eaf918fe287aa898748d76c (patch)
tree2346c640a2a215219b289b28dbf3274a6dbc12ce /gnu/packages/python-web.scm
parentb2696a7211000baaac7d7d4864c23946e0e6fbee (diff)
downloadguix-patches-c19a432652f2fb544eaf918fe287aa898748d76c.tar
guix-patches-c19a432652f2fb544eaf918fe287aa898748d76c.tar.gz
gnu: Add python-grid5000.
* gnu/packages/python-web.scm (python-grid5000): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index df63602236..4234b4bcab 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2022 msimonin <matthieu.simonin@inria.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7786,3 +7787,28 @@ list, create, update, or delete resources (e.g. Order, Product, Collection).")
(description
"This package provides a library to parse and apply patches.")
(license license:expat)))
+
+(define-public python-grid5000
+ (package
+ (name "python-grid5000")
+ (version "1.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/msimonin/python-grid5000")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "097pm8b68ihk29xz9zv29b1x0bhgjb4lfj8zxk2grbsh7wr9dipg")))
+ (build-system python-build-system)
+ (native-inputs (list python-wheel))
+ (propagated-inputs (list python-requests python-ipython python-pyyaml))
+ (arguments
+ (list #:tests? #f)) ; No tests.
+ (home-page "https://pypi.org/project/python-grid5000/")
+ (synopsis "Grid5000 python client")
+ (description
+ "python-grid5000 is a python package wrapping the Grid5000 REST API.
+You can use it as a library in your python project or you can explore the
+Grid5000 resources interactively using the embedded shell.")
+ (license license:gpl3+)))