summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-19 14:09:15 +0000
committerMathieu Othacehe <othacehe@gnu.org>2022-01-20 14:34:00 +0100
commitb9056afc0a3ba16993fb95bbedc735f65c88511c (patch)
treef836d973b84f6ee8d9a245078a606e5ee9742ca8 /gnu/packages/python-web.scm
parentf0e623dde364fc39dd9b5b9a2cd6e991f0b8ea30 (diff)
downloadguix-patches-b9056afc0a3ba16993fb95bbedc735f65c88511c.tar
guix-patches-b9056afc0a3ba16993fb95bbedc735f65c88511c.tar.gz
gnu: Add python-urlgrabber.
* gnu/packages/python-web.scm (python-urlgrabber): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index addd7cf9c3..a91c840052 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4135,6 +4135,35 @@ variety of features, from launching web applications to bootstrapping project
layouts.")
(license license:expat)))
+(define-public python-urlgrabber
+ (package
+ (name "python-urlgrabber")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urlgrabber" version))
+ (sha256
+ (base32 "0fg16zlw49cw7pjq9dhpc5vd35d5zz1mlki55m464qxfmfpzhnh7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test/runtests.py")))))))
+ (propagated-inputs
+ (list python-pycurl python-setuptools python-six))
+ (home-page "http://urlgrabber.baseurl.org/") ; no HTTPS
+ (synopsis "High-level cross protocol url-grabber")
+ (description
+ "@code{urlgrabber} is a library that unifies access to files available on
+the web, FTP or locally. It supports HTTP, FTP and file:// protocols, it
+supports features like HTTP keep-alive, reget, throttling and more.")
+ (license license:lgpl2.1+)))
+
(define-public python2-urlgrabber
(package
(name "python2-urlgrabber")