summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:39:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:39:57 +0300
commitb563526794c14eb2d4325d209ae4b3bcac1704c0 (patch)
tree76cf8e5971cdfce6e07aa5d09c6301517456f0aa /gnu/packages/python-web.scm
parent9c2e6516622d19ca2e484e2c168a1f94f2c96f76 (diff)
downloadguix-patches-b563526794c14eb2d4325d209ae4b3bcac1704c0.tar
guix-patches-b563526794c14eb2d4325d209ae4b3bcac1704c0.tar.gz
gnu: Add python-manuel.
* gnu/packages/python-web.scm (python-manuel): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8a21895228..8abf6a7874 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4132,3 +4132,25 @@ REST APIs. Flask-RESTX encourages best practices with minimal setup. If you ar
decorators and tools to describe your API and expose its documentation properly using
Swagger.")
(license license:bsd-3)))
+
+(define-public python-manuel
+ (package
+ (name "python-manuel")
+ (version "1.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "manuel" version))
+ (sha256
+ (base32
+ "1bdzay7j70fly5fy6wbdi8fbrxjrrlxnxnw226rwry1c8a351rpy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (native-inputs
+ `(("python-zope-testing" ,python-zope-testing)))
+ (home-page "https://pypi.org/project/manuel/")
+ (synopsis "Build tested documentation")
+ (description
+ "Manuel lets you mix and match traditional doctests with custom test syntax.")
+ (license license:asl2.0)))