summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 23:30:26 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 18:07:28 +0100
commitae313005c8c5a5a681f20db076054055ae735c24 (patch)
tree766e8c6dab44192c0295c2ae6490a2b7445882f1 /gnu/packages/python-web.scm
parent5b43b55846ba8234e48d67ef7a0f38ee8086606a (diff)
downloadguix-patches-ae313005c8c5a5a681f20db076054055ae735c24.tar
guix-patches-ae313005c8c5a5a681f20db076054055ae735c24.tar.gz
gnu: Add python-pyscss.
* gnu/packages/python-web.scm (python-pyscss): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 253b68e02c..1d2dfd2442 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -82,6 +82,7 @@
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
#:use-module (gnu packages node)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -775,6 +776,40 @@ JSON Web Algorithms (JWA) - collectively can be used to encrypt and/or sign
content using a variety of algorithms.")
(license license:expat)))
+(define-public python-pyscss
+ (package
+ (name "python-pyscss")
+ (version "1.3.7")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/Kronuz/pyScss")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0701hziiiw67blafgpmjhzspmrss8mfvif7fw0rs8fikddwwc9g6"))))
+ (build-system python-build-system)
+ (arguments
+ ;; XXX: error in test collection, possible incompatibility with Pytest 6.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest" "--pyargs" "scss")))))))
+ (native-inputs
+ (list python-pytest python-pytest-cov))
+ (inputs
+ (list pcre))
+ (home-page "https://github.com/Kronuz/pyScss")
+ (synopsis "Scss compiler for Python")
+ (description "@code{pyScss} is a compiler for Sass, a superset language of
+CSS3 that adds programming capabilities and some other syntactic sugar.")
+ (license license:expat)))
+
(define-public python-jsonpickle
(package
(name "python-jsonpickle")