summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-31 09:21:45 +0200
committerRoel Janssen <roel@gnu.org>2021-05-31 09:21:45 +0200
commitad7c7b5bf62440ee05ff4da908484721d75ca545 (patch)
treef3eba138a231d2722a004981bca5a7f142771bdc /gnu/packages/python-web.scm
parent221141ca70c3692ff505602b08e05e8fe55407f2 (diff)
downloadguix-patches-ad7c7b5bf62440ee05ff4da908484721d75ca545.tar
guix-patches-ad7c7b5bf62440ee05ff4da908484721d75ca545.tar.gz
gnu: Add python-google.
* gnu/packages/python-web.scm (python-google): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f20f1c1f55..81cd4daea2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2014, 2017, 2021 Eric Bavier <bavier@posteo.net>
@@ -4298,6 +4298,25 @@ name resolutions asynchronously.")
for URL parsing and changing.")
(license license:asl2.0)))
+(define-public python-google
+ (package
+ (name "python-google")
+ (version "3.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "google" version))
+ (sha256
+ (base32
+ "1gncv3l11za0mpxvmpaf5n5j3jzp282rz62yml4ha4z55q930d8l"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (home-page "https://breakingcode.wordpress.com/")
+ (synopsis "Python bindings to the Google search engine")
+ (description "This package provides Python bindings for using the
+Google search engine. Its module is called @code{googlesearch}.")
+ (license license:bsd-3)))
+
(define-public python-google-api-client
(package
(name "python-google-api-client")