summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-19 00:09:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-20 22:47:04 -0500
commita5c8aff18937f6739b3b1b9e851c352ac27606a7 (patch)
treed06e676e02eb82985dd522e04e07ace48fefca49 /gnu/packages/python-web.scm
parent9b0991cb51556742e938496a7a2d56ce3457e8b8 (diff)
downloadguix-patches-a5c8aff18937f6739b3b1b9e851c352ac27606a7.tar
guix-patches-a5c8aff18937f6739b3b1b9e851c352ac27606a7.tar.gz
gnu: python-geventhttpclient: Update to 1.4.4.
* gnu/packages/python-web.scm (python-geventhttpclient): Update to 1.4.4.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9765c96fd1..4ec5a3e882 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3037,13 +3037,13 @@ for the basic TCP/IP protocols.")
(define-public python-geventhttpclient
(package
(name "python-geventhttpclient")
- (version "1.3.1")
+ (version "1.4.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "geventhttpclient" version))
(sha256
(base32
- "07d0q3wzmml75227r6y6mrl5a0zpf4v9gj0ni5rhbyzmaj4az1xx"))
+ "1hy4qm9d3r69n5199i7qjji1v7718n7cxbj8ggi0njify99m37pm"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3071,7 +3071,8 @@ for the basic TCP/IP protocols.")
"-k" (string-append "not test_cookielib_compatibility"))
#t)))))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-dpkt" ,python-dpkt)
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-certifi" ,python-certifi)
("python-gevent" ,python-gevent)