summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-19 14:09:07 +0000
committerMathieu Othacehe <othacehe@gnu.org>2022-01-20 14:34:00 +0100
commita53abfb07575485a66f17a2f6e262c93f2c0fe73 (patch)
tree42bf3f5da768e8659ee5a2ec3982d16661fc55be /gnu/packages/python-web.scm
parent97b767b007789542f18fccc806272471824421e4 (diff)
downloadguix-patches-a53abfb07575485a66f17a2f6e262c93f2c0fe73.tar
guix-patches-a53abfb07575485a66f17a2f6e262c93f2c0fe73.tar.gz
gnu: Remove python2-s3transfer.
* gnu/packages/python-web.scm (python2-s3transfer): Remove variable. * gnu/packages/python-web.scm (python-s3transfer)[properties]: Remove field. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6563d0dd44..295cebe155 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3334,15 +3334,7 @@ Betamax that may possibly end up in the main package.")
(description "S3transfer is a Python library for managing Amazon S3
transfers.")
(home-page "https://github.com/boto/s3transfer")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-s3transfer))))))
-
-(define-public python2-s3transfer
- (let ((base (package-with-python2 (strip-python2-variant python-s3transfer))))
- (package/inherit base
- (native-inputs
- `(("python2-futures" ,python2-futures)
- ,@(package-native-inputs base))))))
+ (license license:asl2.0)))
(define-public python-slimit
(package