summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 21:46:23 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:17 +0100
commit9f6b44b123d85fae78acfcb58e8af3895a5a6dba (patch)
tree78cf797ea6082694e71ab82415297edcbe36f698 /gnu/packages/python-web.scm
parentadc344c5c6208bb48ec5b63e94e37d7c5c5fbfa9 (diff)
downloadguix-patches-9f6b44b123d85fae78acfcb58e8af3895a5a6dba.tar
guix-patches-9f6b44b123d85fae78acfcb58e8af3895a5a6dba.tar.gz
gnu: python-flask-restx: Update to 0.5.1.
* gnu/packages/python-web.scm (python-flask-restx): Update to 0.5.1. [arguments]: Disable one more test.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1c2211e6dd..708528983c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5639,7 +5639,7 @@ based on filters.")
(define-public python-flask-restx
(package
(name "python-flask-restx")
- (version "0.2.0")
+ (version "0.5.1")
(source
;; We fetch from the Git repo because there are no tests in the PyPI
;; archive.
@@ -5650,7 +5650,7 @@ based on filters.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xf2vkmdngp9cv9klznizai4byxjcf0iqh1pr4b83nann0jxqwy7"))))
+ (base32 "18vrmknyxw6adn62pz3kr9kvazfgjgl4pgimdf8527fyyiwcqy15"))))
(build-system python-build-system)
(propagated-inputs
(list python-aniso8601 python-flask python-jsonschema python-pytz))
@@ -5668,7 +5668,8 @@ based on filters.")
(lambda _
(invoke "pytest" "--benchmark-skip" "-k"
;; Those tests need internet access
- "not test_check and not test_valid_value_check"))))))
+ "not test_check and not test_valid_value_check \
+and not test_override_app_level"))))))
(home-page "https://github.com/python-restx/flask-restx")
(synopsis
"Framework for fast, easy and documented API development with Flask")