summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-12-16 09:04:57 +0100
committerLars-Dominik Braun <lars@6xq.net>2021-12-16 09:04:57 +0100
commit974264af3782be047b4fb1765fbb67964d67a643 (patch)
treead5f4a3c64a5f161aff68ac9d7f75372cc074037 /gnu/packages/python-web.scm
parent44e1300994b783a758de7b3cf84287811ece5e80 (diff)
downloadguix-patches-974264af3782be047b4fb1765fbb67964d67a643.tar
guix-patches-974264af3782be047b4fb1765fbb67964d67a643.tar.gz
gnu: python-flask-restful: Rewrite import.
It seems a function inside python-flask moved to a different module. * gnu/packages/python-web.scm (python-flask-restful)[arguments]: Add phase rewriting imports from flask.helpers to flask.scaffold.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c04f2fbaf7..61a34bfc63 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3335,6 +3335,13 @@ pretty printer and a tree visitor.")
(base32
"05b9lzx5yc3wgml2bcq50lq35h66m8zpj6dc9advcb5z3acsbaay"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-imports
+ (lambda _
+ (substitute* "flask_restful/__init__.py"
+ (("flask\\.helpers") "flask.scaffold")))))))
(propagated-inputs
(list python-aniso8601 python-flask python-pycrypto python-pytz))
(native-inputs