summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
commit8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f (patch)
treeadc5d29e9c2dcda5befa0ca81f1af8df23294947 /gnu/packages/python-web.scm
parent2f33a7321e5e37d37f57c229c8079cb4ffd10834 (diff)
parent3374e9207f5244c20402a3c5513fe562140fef47 (diff)
downloadguix-patches-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar
guix-patches-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm65
1 files changed, 64 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b1809c6d9a..fa634c2ecd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
@@ -3030,3 +3030,66 @@ applications using Publish and Subscribe (PubSub) and routed Remote Procedure
Calls (rRPC). It is ideal for distributed, multi-client and server applications
such as IoT applications or multi-user database-driven business applications.")
(license license:expat)))
+
+(define-public python-ws4py
+ (package
+ (name "python-ws4py")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ws4py" version))
+ (sha256
+ (base32
+ "10slbbf2jm4hpr92jx7kh7mhf48sjl01v2w4d8z3f1p0ybbp7l19"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'python3.7-compatibility
+ (lambda _
+ (substitute* '("ws4py/server/tulipserver.py"
+ "ws4py/async_websocket.py")
+ (("asyncio.async")
+ "asyncio.ensure_future"))
+ #t))
+ ;; We don't have a package for cherrypy.
+ (add-after 'unpack 'remove-cherrypy-support
+ (lambda _
+ (delete-file "ws4py/server/cherrypyserver.py")
+ #t)))))
+ (propagated-inputs
+ `(("python-gevent" ,python-gevent)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://github.com/Lawouach/WebSocket-for-Python")
+ (synopsis "WebSocket client and server library")
+ (description
+ "This package provides a WebSocket client and server library for
+Python.")
+ (license license:bsd-3)))
+
+;; kaldi-gstreamer-server does not yet work with python-ws4py > 0.3.2
+(define-public python2-ws4py-for-kaldi-gstreamer-server
+ (package (inherit python-ws4py)
+ (name "python2-ws4py")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ws4py" version))
+ (sha256
+ (base32
+ "12ys3dv98awhrxd570vla3hqgzq3avjhq4yafhghhq3a942y1928"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; We don't have a package for cherrypy.
+ (add-after 'unpack 'remove-cherrypy-support
+ (lambda _
+ (delete-file "ws4py/server/cherrypyserver.py")
+ #t)))))
+ (propagated-inputs
+ `(("python-gevent" ,python2-gevent)
+ ("python-tornado" ,python2-tornado)))))