summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 23:30:34 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 18:07:31 +0100
commit7fd7416728a1997341d286ac28e845c2b59e8f20 (patch)
tree8c942d57c5234268b33253979098a52988ec252d /gnu/packages/python-web.scm
parentb2bd183b14d84cca204ca576a50974b62ad9513d (diff)
downloadguix-patches-7fd7416728a1997341d286ac28e845c2b59e8f20.tar
guix-patches-7fd7416728a1997341d286ac28e845c2b59e8f20.tar.gz
gnu: python-websocket-client: Update to 0.59.0.
* gnu/packages/python-web.scm (python-websocket-client): Update to 0.59.0. [source]: Update PyPI URI. Make some cosmetic changes. [arguments]<#:phases>: Add phase 'skip-network-test. [native-inputs]: Add python-pysocks. [home-page]: Follow redirect. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c60eebf051..aaf8a57f6f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2413,18 +2413,27 @@ verification of the SSL peer.")
(define-public python-websocket-client
(package
(name "python-websocket-client")
- (version "0.54.0")
+ (version "0.59.0") ; tests hang on newer versions
(source
(origin
(method url-fetch)
- (uri (pypi-uri "websocket_client" version))
+ (uri (pypi-uri "websocket-client" version))
(sha256
- (base32
- "0j88zmikaypf38lvpkf4aaxrjp9j07dmy5ghj7kli0fv3p4n45g5"))))
+ (base32 "0p0cz2mdissq7iw1n7jrmsfir0jfmgs1dvnpnrx477ffx9hbsxnk"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-network-test
+ (lambda _
+ ;; This test requires networking.
+ (substitute* "websocket/tests/test_http.py"
+ (("def testConnect") "def _testConnect")))))))
+ (native-inputs
+ (list python-pysocks))
(propagated-inputs
(list python-six))
- (home-page "https://github.com/liris/websocket-client")
+ (home-page "https://github.com/websocket-client/websocket-client")
(synopsis "WebSocket client for Python")
(description "The Websocket-client module provides the low level APIs for
WebSocket usage in Python programs.")