summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-12 13:40:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-12 17:39:56 +0300
commit79a7c6e81144e34cc6f32b9c022e79f212f7bbb8 (patch)
tree2a7ec5ea1db857cdecc8d69e16e70e0af5153c2d /gnu/packages/python-web.scm
parentaba4cdc87f1146ccb018d73816d4ec950865a9ae (diff)
downloadguix-patches-79a7c6e81144e34cc6f32b9c022e79f212f7bbb8.tar
guix-patches-79a7c6e81144e34cc6f32b9c022e79f212f7bbb8.tar.gz
gnu: python-tornado-6: Adjust test timeout.
* gnu/packages/python-web.scm (python-tornado-6)[arguments]: Adjust custom 'check phase to allow a longer test timeout.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 87e65f4d36..6bb73fa6d2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2075,6 +2075,7 @@ connection to each user.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
+ (setenv "ASYNC_TEST_TIMEOUT" "25") ; Like in tox.ini.
(invoke "python" "-m" "tornado.test.runtests")))))))
(native-inputs
(list python-certifi))