summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-30 17:30:46 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 22:36:28 +0200
commit782ec059266548fe11da3a5704441a6118d0c762 (patch)
tree06399451ca252a4848bbd74de789723109d13cb3 /gnu/packages/python-web.scm
parentb6e1ba61042c14c9391514472e436e29b2a5167d (diff)
downloadguix-patches-782ec059266548fe11da3a5704441a6118d0c762.tar
guix-patches-782ec059266548fe11da3a5704441a6118d0c762.tar.gz
gnu: python-hypercorn: Remove "python-" prefix from name.
Hypercorn is mainly a CLI application but also supports a module interface. * gnu/packages/python-web.scm (python-hypercorn): New deprecated variable. (hypercorn): Renamed from the respective above. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d181046ac4..e230408299 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1635,9 +1635,9 @@ choose to use, ensuring that you can communicate via WebSockets, as defined in
RFC6455, regardless of your programming paradigm.")
(license license:expat)))
-(define-public python-hypercorn
+(define-public hypercorn
(package
- (name "python-hypercorn")
+ (name "hypercorn")
(version "0.10.2")
(source
(origin
@@ -1653,6 +1653,7 @@ RFC6455, regardless of your programming paradigm.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv"))))))
+ ;; Propagate because Hypercorn also exposes functionality over a module.
(propagated-inputs
`(("python-h11" ,python-h11)
("python-h2" ,python-h2)
@@ -1677,6 +1678,9 @@ WebSockets (over HTTP/1 and HTTP/2), ASGI/2, and ASGI/3 specifications. It can
utilise asyncio, uvloop, or trio worker types.")
(license license:expat)))
+(define-public python-hypercorn
+ (deprecated-package "python-hypercorn" hypercorn))
+
(define-public python-querystring-parser
(package
(name "python-querystring-parser")