summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 11:29:38 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 12:42:47 +0100
commit74f38150981df1416e46b1fa6a2abf4f11e7281c (patch)
treefdc189b3a8f3d051295b51bc81159e5ddd590e0c /gnu/packages/python-web.scm
parente92961a687c9626daadc6d2585f543f023d468b5 (diff)
downloadguix-patches-74f38150981df1416e46b1fa6a2abf4f11e7281c.tar
guix-patches-74f38150981df1416e46b1fa6a2abf4f11e7281c.tar.gz
gnu: python-flask-migrate: Update to 3.1.0.
* gnu/packages/python-web.scm (python-flask-migrate): Update to 3.1.0. [source]: Change to GIT-FETCH. [propagated-inputs]: Remove PYTHON-SCRIPT and PYTHON-SQLALCHEMY.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c6e760ce35..483abec2d5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3769,25 +3769,24 @@ itself.")
(define-public python-flask-migrate
(package
- (name "python-flask-migrate")
- (version "2.5.3")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "Flask-Migrate" version))
- (sha256
- (base32
- "1vip9ww6l18dxffjsggm83k71zkvihxpnhaswpv8klh95s6517d6"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-flask python-alembic python-sqlalchemy
- python-flask-script python-flask-sqlalchemy))
- (home-page "https://github.com/miguelgrinberg/flask-migrate/")
- (synopsis "SQLAlchemy database migrations for Flask programs using
+ (name "python-flask-migrate")
+ (version "3.1.0")
+ (home-page "https://github.com/miguelgrinberg/flask-migrate/")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0zj7qpknvlhrh4fsp5sx4fwyx3sp41ynclka992zympm3xym9zyq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-flask python-alembic python-flask-sqlalchemy))
+ (synopsis "SQLAlchemy database migrations for Flask programs using
Alembic")
- (description "This package contains SQLAlchemy database migration tools
+ (description "This package contains SQLAlchemy database migration tools
for Flask programs that are using @code{python-alembic}.")
- (license license:expat)))
+ (license license:expat)))
(define-public python-genshi
(package