summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 13:40:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 13:40:39 +0200
commit6934f094a627a0e663db15f6eab2a0c97d104ad1 (patch)
tree9b2edef4eb7394486d4728561df98b6b23d9efd0 /gnu/packages/python-web.scm
parente41ca0a49a2c9b73a6bf54202b91aaf3be701863 (diff)
downloadguix-patches-6934f094a627a0e663db15f6eab2a0c97d104ad1.tar
guix-patches-6934f094a627a0e663db15f6eab2a0c97d104ad1.tar.gz
gnu: Add python-google-cloud-core.
* gnu/packages/python-web.scm (python-google-cloud-core): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index df6c3f3e40..e49653441b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -97,6 +97,7 @@
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages rpc)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages texinfo)
@@ -6892,6 +6893,33 @@ common protos in the @code{googleapis/api-common-protos} repository.")
clients.")
(license license:asl2.0)))
+(define-public python-google-cloud-core
+ (package
+ (name "python-google-cloud-core")
+ (version "2.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-cloud-core" version))
+ (sha256
+ (base32 "0sa66kidgr32dfq9ngha9l362xnqvnqqmssn5my1gd3lc6g65apx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-google-api-core python-google-auth))
+ (native-inputs
+ (list python-grpcio python-pytest))
+ (home-page "https://github.com/googleapis/python-cloud-core")
+ (synopsis "Google Cloud API client core library")
+ (description "This library defines common helpers (e.g. base @code{Client}
+classes) used by all of the @code{google-cloud-*} packages.")
+ (license license:asl2.0)))
+
(define-public python-w3lib
(package
(name "python-w3lib")